Microsoft SSO issue

Incident Report for SupaHuman

Resolved

This incident has been resolved.
Posted Aug 12, 2026 - 09:54 NZST

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 12, 2026 - 09:17 NZST

Investigating

We are currently resolving an issue with Microsoft SSO logins. A fix is in progress and should be resolved within the hour
Posted Aug 12, 2026 - 09:17 NZST
This incident affected: VETos Platform.