Resource edits are not saving properly

Incident Report for SupaHuman

Resolved

This incident has been resolved.
Posted Aug 24, 2026 - 08:39 NZST

Update

We are continuing to work on a fix for this issue.
Posted Aug 19, 2026 - 10:26 NZST

Identified

Users are being notified of successfully saved changes after editing a resource, however when exiting the resource view users are being advised there are unsaved changes that will be discarded if they leave.

This issue has been identified and a fix is being worked on.
Posted Aug 19, 2026 - 10:26 NZST
This incident affected: Resource Generation.