Resource downloads to templates failing

Incident Report for SupaHuman

Resolved

This issue has now been resolved
Posted Jun 12, 2026 - 09:51 NZST

Identified

This issue has been identified and being worked on
Posted Jun 12, 2026 - 09:03 NZST
This incident affected: Resource Generation.